Четверг, 12 Декабря 2019, 22:22

Приветствую Вас Гость

[ Новые сообщения · Игроделы · Правила · Поиск ]
  • Страница 1 из 1
  • 1
Форум игроделов » Программирование » Скриптовые языки программирования » Lua - подскажите мне (установка, учебники)
Lua - подскажите мне
BetMoraДата: Понедельник, 22 Февраля 2010, 20:43 | Сообщение # 1
постоянный участник
Сейчас нет на сайте
Как установить lua? по install файлу в корне каталога пытался.. не получилось.. и если есть какие-то учебники, туторы не он-лайн.. киньте ссылку или название.. заранее спс

п.с. создал топик здесь т.к. скриптовая система для Си++ же..


Перекуём баги на фичи!

Сообщение отредактировал BetMora - Понедельник, 22 Февраля 2010, 20:43
AkyltistДата: Понедельник, 22 Февраля 2010, 21:36 | Сообщение # 2
заслуженный участник
Сейчас нет на сайте


--------------------------------- Установка под линукс! ---------------------------------

1.------- + Установка lua из пакетa для Debian:
apt-get install liblua50-dev liblualib50-dev

2.------- + Установка lua из пакетa для Gentoo:
emerge lua

Установка lua из исходников

1. Скачиваем lua
2. Скачиваем luasocket

3. Нужно распаковать сначала luasocket, а потом уже lua в каталог luasocket/src
4. Из каталога luasocket/src/lua вызываем
./configure
make
make install
make so
make soinstall

5. Берем модуль compat-5.1 http://luaforge.net/frs/?group_id=82 без него работать не будет.
6. Распаковываем исходники luasocket и туда же распаковываем compat-5.1.
7. Редактируем файл config

  • - раскомментировать строчку LUAINC=-Ilua-5.1.4/src заодно подредактировав версию установленой lua
  • - раскомментировать строчку COMPAT=compat-5.1r5 - здесь указать куда был распакован модуль compat-5.1

Далее сделать
make
make install

8. Запускаем lua, появится приглашение: Lua 5.1.2 Copyright © 1994-2007 Lua.org, PUC-Rio
9. Набираем
-> socket = require("socket")
-> print(socket._VERSION)

10. Получаем в ответ:
--> LuaSocket X.X.X


--------------------------------- Установка под форточку! ---------------------------------

Качаем Lua_V5.1.4.30.exe с LuaForge.
Или Качаем Lua_V5.1.4.30.exe с Google Code.

Лично я предпочитаю с LuaForge, не люблю ажиотажные конторы.
Качаем устанавливаем по принципу "Далее -- Ок -- Нас все устраивает"

Ну и как во всех кинотеатрах Сан-Франциско:
Microsoft Windows XP [Версия 5.1.2600]
(С) Корпорация Майкрософт, 1985-2001.

C:\Documents and Settings\root>lua
Lua 5.1.4 Copyright © 1994-2008 Lua.org, PUC-Rio
>

Ну или для самых ленивых: Пуск - Программы - Lua - Lua (Command Line)

Ну и без мороки для теста скриптов юзаем lExecutor Выбираем файл, Выбираем Output директорию и файл ну и Execute.

nilremДата: Понедельник, 22 Февраля 2010, 21:41 | Сообщение # 3
Просветленный разум
Сейчас нет на сайте
Akyltist,
Ты чего? Тут Линукс людям разве что в кошмарах снится. А от командной строки они вообще в обморок падают.)


Windmill 2

WindMill 2D Game Engine
BetMoraДата: Понедельник, 22 Февраля 2010, 22:21 | Сообщение # 4
постоянный участник
Сейчас нет на сайте
Quote (nilrem)
Ты чего? Тут Линукс людям разве что в кошмарах снится. А от командной строки они вообще в обморок падают.)

гы=)))
Akyltist, бигист фенкс)

хех, я походу сначала под линукс скачал biggrin и пытался командной строкой..

пс. Топик можно клозить.


Перекуём баги на фичи!

Сообщение отредактировал BetMora - Понедельник, 22 Февраля 2010, 22:23
AnotherNoobДата: Воскресенье, 07 Марта 2010, 21:04 | Сообщение # 5
заслуженный участник
Сейчас нет на сайте
Quote (nilrem)
Akyltist,
Ты чего? Тут Линукс людям разве что в кошмарах снится. А от командной строки они вообще в обморок падают.)

Ну... далеко не все))
Akyltist, спасибо. Может, пригодится.
Форум игроделов » Программирование » Скриптовые языки программирования » Lua - подскажите мне (установка, учебники)
  • Страница 1 из 1
  • 1
Поиск:

Все права сохранены. GcUp.ru © 2008-2019 Рейтинг