Четверг, 22 Ноября 2018, 14:30

Приветствую Вас Гость

[ Новые сообщения · Игроделы · Правила · Поиск ]
  • Страница 1 из 1
  • 1
Модератор форума: beril  
Форум игроделов » Движки для разработки игр и сложные системы разработки » Unity » Соответствие версий .NET и Unity Mono
Соответствие версий .NET и Unity Mono
8Observer8Дата: Воскресенье, 20 Марта 2016, 18:32 | Сообщение # 1
заслуженный участник
Сейчас нет на сайте
Если открыть настройки Player, то можно увидеть выбор: .NET 2.0 или .NET 2.0 Subset

Думаю, что Subset - это урезанная версия. Скорее всего, конечный проект будет весить меньше. Поправьте если не так, но вопрос не в этом.

Я думал, что используется Mono, версия которой эквивалентна .NET 2.0, но когда я попробовал использовать Linq, я обнаружил, что он работает. Linq был введёт в .NET 3.5: https://ru.wikipedia.org/wiki/.NET_Framework#.NET_Framework_3.5

Потом я посмотрел, что в Mono появился Linq в версии 2.0

Правильно ли я понимаю, что в настройках Unity ошибка? Там нужно было написать либо .NET 3.5, либо Mono 2.0?


Туториалы по играм на C# и Unity от НубТутс

Сообщение отредактировал 8Observer8 - Воскресенье, 20 Марта 2016, 19:35
TLTДата: Воскресенье, 20 Марта 2016, 20:03 | Сообщение # 2
Сейчас нет на сайте
Возможно от 2.0...

Дао, выраженное словами, не есть истинное Дао.
berilДата: Воскресенье, 20 Марта 2016, 21:11 | Сообщение # 3
Я не ленивый, я — энергосберегающий
Сейчас нет на сайте
Да юнити вроде поддерживает NEt 3.5. При желании можно так же с помощью плагина юзать фишки из C# 6.0



Накодил? Убери за собой!
Инвентарь в Unity(UI)
Инвентарь в Unity(GUI)
LertmindДата: Воскресенье, 20 Марта 2016, 22:05 | Сообщение # 4
заслуженный участник
Сейчас нет на сайте
Ошибки нет, в инете пишут, что в Unity своя версия Mono: поддержка C# 3.0, который пришёл с .NET 3.5 и в котором есть Linq, но при этом CLR и библиотека .NET 2.0, т. е. это не полноценный .NET 3.5.

Добавлено (20 марта 2016, 22:05)
---------------------------------------------

Цитата Lertmind ()
Да юнити вроде поддерживает NEt 3.5.
Нет.
Цитата beril ()
При желании можно так же с помощью плагина юзать фишки из C# 6.0
Ограниченно. Первое что нашёл https://bitbucket.org/alexzzzz/unity-c-5.0-and-6.0-integration/src, dynamic там не работает.
Форум игроделов » Движки для разработки игр и сложные системы разработки » Unity » Соответствие версий .NET и Unity Mono
  • Страница 1 из 1
  • 1
Поиск:

Все права сохранены. GcUp.ru © 2008-2018 Рейтинг